#1  
Gammal 2015-02-10, 13:28
Joakim.e
 
Medlem sedan: okt 2006
Inlägg: 404
Arg Repad digital bild
Vid genomgång av gamla bilder från 2008 har jag påträffat ca 40-50 bilder med "repor", ja de påminner ju om repor i diabilder, men här är det någon pixelrad som ramlat bort. Det kan vara på olika delar av bilden, både kort- och långsidan och olika ställen, ibland två repor, och ibland bara en del av pixelraden. Två bilder har blivit mer traditionellt korrupta, där halva bilden försvunnit. Jag hade vid den tiden en extern digital disk som ibland kunde glappa vid isläsningen från minneskortet så det kan vara problemet. Eller kan sådant här uppkomma i efterhand efter flera års digital lagring (har vidarekopierats i omgångar till andra hårddiskar)? Jag använde mest ViewNX på den tiden och där syns det ej ens i helskärm (som väl bygger på den i RAW-filen inbyggda jpg-bilden). Nu använder jag mest Lightroom och då syns ju felet direkt. Det syns också direkt då jag öppnar filen i Capture NX2.
Jag har alltid formaterat minneskorten direkt efter användning, i kameran. Däremot kan jag radera usla bilder ibland direkt i kameran vid fotograferingen. Verkar dock inte ha varit drabbad på senare år, trots att jag använder samma kamera (D300) och samma minneskort ingår fortfarande i de jag kör.
Har inte lyckats hitta något inlägg om detta på nätet men det kan väl knappast vara unikt.

Frågan är 1) hur man undviker detta, kan väl inte vara ngt som uppkommit efter flera år väl utan rimligtvis vid första inläsningen till hårddisken alternativt redan vid skrivningen på minneskortet i kameran.
2) hur lagar man enklast detta (har Lightroom, Capture NX2 och en utvärderingsversion av Photoshop CC). De flesta bilder har jag dubletter av men en del skulle jag vilja fixa till.
Bifogade miniatyrer
Klicka på bilden för en större version

Namn:	DSC_9024a.jpg
Visningar:	140
Storlek:	343.6 KB
ID:	137537  

  #2  
Gammal 2015-02-10, 13:50
lumor_
 
Medlem sedan: jun 2006
Inlägg: 1 581
Vet inte hur det uppkommit eller hur du kan slippa det. Har aldrig sett det tidigare och det borde inte bli av långvarig lagring (då skulle man sett det på en massa gamla bilder, inte bara dina).

Det enklaste sättet att laga det är kanske att helt enkelt ta bort den raden. Det borde inte märkas i de allra flesta bilder. Gör t ex så här i PS eller liknande program:
1. markera allt till höger om den skadade raden med rektangulär markering
2. flytta det markerade en pixel till vänster (i PS ctrl+T, för transform, och sedan ett tryck på vänster piltangent för att flytta det hela en pixel åt vänster)
3. beskär bort den tomma raden med pixlar som bildats längst till höger.

Ett annat alternativ, ifall din version av PS har Fill Content aware, är att markera den rad som är skadad, trycka på delete och välja Content aware i fönstret "Fill" som dyker upp.
  #3  
Gammal 2015-02-10, 14:12
Joakim.e
 
Medlem sedan: okt 2006
Inlägg: 404
lumor_ skrev: Vet inte hur det uppkommit eller hur du kan slippa det. Har aldrig sett det tidigare och det borde inte bli av långvarig lagring (då skulle man sett det på en massa gamla bilder, inte bara dina).

Det enklaste sättet att laga det är kanske att helt enkelt ta bort den raden. Det borde inte märkas i de allra flesta bilder. Gör t ex så här i PS eller liknande program:
1. markera allt till höger om den skadade raden med rektangulär markering
2. flytta det markerade en pixel till vänster (i PS ctrl+T, för transform, och sedan ett tryck på vänster piltangent för att flytta det hela en pixel åt vänster)
3. beskär bort den tomma raden med pixlar som bildats längst till höger.

Ett annat alternativ, ifall din version av PS har Fill Content aware, är att markera den rad som är skadad, trycka på delete och välja Content aware i fönstret "Fill" som dyker upp.
Tackar för tips om lagning, ska pröva det. Nej med bara en pixelrad märks det knappast om det inte går tvärs genom centrala delen av bilden. Märkligt att det uppkommit på så många bilder, och rimligen borde det ju inte vara första gången något liknande hänt någon. Det är dessutom inom loppet av 2-3 månader som det uppkom, förhoppningsvis inte som du sa något med lagringen.
  #4  
Gammal 2015-02-10, 14:41
Joakim.e
 
Medlem sedan: okt 2006
Inlägg: 404
Hittade en tutorial
https://www.youtube.com/watch?v=v91p8upSzH0
Väldigt kraftfullt verktyg men får det inte att funka i CC 2014. Fyllning på Redigera-menyn är utgråad och går inte att markera. Beror nog snarare på att jag inte vet hur man gör och att det görs på annat sätt än i CS5. Någon som vet?
  #5  
Gammal 2015-02-10, 14:49
Joakim.e
 
Medlem sedan: okt 2006
Inlägg: 404
Jag kommer in på fyllning men "innehållsmedveten" som content-aware heter på svenska går ej att markera, den är utgråad. Förgrundsfärg är förvalt.
  #6  
Gammal 2015-02-10, 15:19
lynxx
 
Medlem sedan: jan 2002
Inlägg: 606
Joakim.e skrev: Jag kommer in på fyllning men "innehållsmedveten" som content-aware heter på svenska går ej att markera, den är utgråad. Förgrundsfärg är förvalt.
Testa "Markera allt" Sedan väljer du innehållsmedveten skalning eller
markera området runt strecket med lassot och sedan kör du *backspace* och väljer innehållsmedveten...... (content aware)
Bifogade miniatyrer
Klicka på bilden för en större version

Namn:	scratch2.jpg
Visningar:	76
Storlek:	49.5 KB
ID:	137539  

  #7  
Gammal 2015-02-10, 15:38
Joakim.e
 
Medlem sedan: okt 2006
Inlägg: 404
lynxx skrev: Testa "Markera allt" Sedan väljer du innehållsmedveten skalning eller
markera området runt strecket med lassot och sedan kör du *backspace* och väljer innehållsmedveten...... (content aware)
Funkade utmärkt! Stort tack!
Besvara

Bokmärken

Taggar
korrupt fil , minneskort , reparera , skada

Ämnesverktyg
Betygsätt det här ämnet
Betygsätt det här ämnet:



Alla tider är GMT +1. Klockan är nu 17:16.



B+W Filter