Annons
  #1  
Gammal 2015-10-30, 12:46
martin991
 
Medlem sedan: apr 2011
Inlägg: 169
Tummen ner Försvunna nyckelord!!!
Hej!
Jag har i flera dagar jobbat med att lägga till nyckelord till mitt bibliotek. Backup görs regelbundet via TimeMachine.
Igår krashade LR och när jag startade igen så hände konstiga saker. Bilder som jag importerat under dagen var försvunna och nyckelord som jag lagt in under dagen var också borta.
Som tur var så hade jag en Time Machine backup som bara var en halvtimme gammal. Återställde biblioteksfil, previews, och filbiblioteket.

Men detta hjälpte inte utan filerna som jag ändrat hade tappat alla justeringar i metadata och nyckelord. Jag hade efter jag la in nyckelorden så flyttade jag filerna från intern disk till en NAS. Den flytten fanns med i biblioteket men som sagt inte nyckelorden eller förändring av metadata, som tex färg-etiketter.

Nu har jag gjort en del ändringar i biblioteket efter detta hände så att återställa igen från en annan säkerhetskopia är inte aktuellt. Men om det händer igen så är jag nyfiken på om man kan göra något annat för att slippa jobbet med att lägga in allt igen.
Jag har testat att välja "läs in metadata från fil" och då ändras färgkoden men inga nyckelord läggs till. Jag gissar att nyckelorden inte sparas i bildfilen utan i katalogfilen. Vilket gör det kört för mig...

Tacksam för tips!

Med vänlig hälsning Martin
  #2  
Gammal 2015-10-30, 12:57
rayoflight
 
Medlem sedan: mar 2013
Inlägg: 41
Glad
Hej! Jag sparar alltid nyckelorden i bildfilen. Bara att trycka Ctrl s när man taggat bilden. LR har kraschat 1 gång för mig, och då var jag glad för vad jag gjort.
  #3  
Gammal 2015-10-30, 13:04
martin991
 
Medlem sedan: apr 2011
Inlägg: 169
rayoflight skrev: Hej! Jag sparar alltid nyckelorden i bildfilen. Bara att trycka Ctrl s när man taggat bilden. LR har kraschat 1 gång för mig, och då var jag glad för vad jag gjort.
Om jag trycker Ctrl S nu, sparas alla nyckelord i hela biblioteket till filerna då? Jag måste förstås markera alla bilderna innan?
  #4  
Gammal 2015-10-30, 14:11
Mr Kane
 
Medlem sedan: feb 2008
Inlägg: 169
rayoflight skrev: Hej! Jag sparar alltid nyckelorden i bildfilen. Bara att trycka Ctrl s när man taggat bilden. LR har kraschat 1 gång för mig, och då var jag glad för vad jag gjort.
Finns det några nackdelar med att spara i nyckelorden i bildfilen från LR? Kan de läsas från andra program?
  #5  
Gammal 2015-10-30, 15:41
reboot81
 
Medlem sedan: sep 2007
Inlägg: 1 732
martin991 skrev: Hej!
Jag har i flera dagar jobbat med att lägga till nyckelord till mitt bibliotek. Backup görs regelbundet via TimeMachine.
Igår krashade LR och när jag startade igen så hände konstiga saker. Bilder som jag importerat under dagen var försvunna och nyckelord som jag lagt in under dagen var också borta.
Som tur var så hade jag en Time Machine backup som bara var en halvtimme gammal. Återställde biblioteksfil, previews, och filbiblioteket.

Men detta hjälpte inte utan filerna som jag ändrat hade tappat alla justeringar i metadata och nyckelord. Jag hade efter jag la in nyckelorden så flyttade jag filerna från intern disk till en NAS. Den flytten fanns med i biblioteket men som sagt inte nyckelorden eller förändring av metadata, som tex färg-etiketter.

Nu har jag gjort en del ändringar i biblioteket efter detta hände så att återställa igen från en annan säkerhetskopia är inte aktuellt. Men om det händer igen så är jag nyfiken på om man kan göra något annat för att slippa jobbet med att lägga in allt igen.
Jag har testat att välja "läs in metadata från fil" och då ändras färgkoden men inga nyckelord läggs till. Jag gissar att nyckelorden inte sparas i bildfilen utan i katalogfilen. Vilket gör det kört för mig...

Tacksam för tips!

Med vänlig hälsning Martin
Märkligt, om du hade en 30min gammal TM-backup så borde ju allt finnas med. Men kanske var den slutförd för 30min sedan, och som kanske pågått halva dagen, där LR-filerna som kopierades var flera timmar gamla?

Du kan ju även låta LR göra backup emellanåt. Kanske något för dig att göra regelbundet tills du "vet" att LR inte kommer krascha var tredje session.
Var bilderna borta från disk eller bara från katalogen? Om de bara var borta från LR, provade du att synkronisera aktuell mapp?
Nyckelord lagras väl inte i bildfilen utan antingen i katalogen eller i XMP-filen? Så läsa in metadata från fil borde väl då vara inläsning från XMP-filen (sidecarfilen)?

Beroende på hur stor din katalog och preview fil är så kanske du skall exludera previewfilen från TM-backupen. Previewfilen kan väl vara trevlig att ha om det händer något, men det är ju katalogen som har något riktigt värde. Min katalog ligger på 2GB, preview på 30GB. Vilken ligger först i kö för TM? Eftersom man inte vet så har jag valt bort att göra backup på den, hellre veta att previewfilen aldrig kommer hindra katalogfilen från att backupas.

LR gör bara backup på katalogen. Vill du få med ALLA inställningar och filer (ej bildfiler!) så rekommenderar jag http://www.photographers-toolbox.com...n/tpglrbackup/.
  #6  
Gammal 2015-10-30, 21:22
martin991
 
Medlem sedan: apr 2011
Inlägg: 169
Har nu listat ut vad som kan ha hänt.
När man startar LR så bildar den ett par temporära filer som lagrar någon form av information, kanske om arbetet du utför så länge programmet är öppet. När du sedan stänger så gissar jag att den skriver över informationen i temp-filerna till de vanliga filerna.

När LR kraschade för mig så hade jag haft igång LR i mer än ett dygn och när jag återställde så återställde jag bara de vanliga filerna, inte temp-filerna. Anledning till detta var att LR var avstängt när jag återställde så de filerna som syntes i min mapp var bara de vanliga. Jag tänkte att det kanske bara ställer till konflikter om jag även återställer temp-filerna, som bara finns när programmet är igång, nu är programmet är avstängt...
Lite svårt att förklara men ni kanske förstår?
Besvara

Bokmärken

Taggar
backup , katalogfil , lightroom , metadata , nyckelord

Ämnesverktyg
Betygsätt det här ämnet
Betygsätt det här ämnet:



Alla tider är GMT +1. Klockan är nu 10:08.



Miops Capsule360